The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Wed Jan 17, 2018 7:47 pm

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Wed Mar 30, 2016 1:56 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Wed Mar 30, 2016 1:09 pm
Posts: 2
Hi all,

My lab is starting to test out the new ADFR program and see how it might enhance our current use of AutoDock Vina for ligand-receptor docking experiments, and we're particularly interested in using the new flexible residue capacity. However, I've encountered some trouble trying to use AGFR to set our receptors up for docking.

We use the I-TASSER and ModRefiner programs to generate and refine receptors from primary sequences, and then AutoDock Tools 1.5.6 to generate .pdbqt files for docking. When I load these into AGFR (Windows OS), neither the 'docking box' nor the 'flexible residue' dialogue boxes work, in that checking the boxes for those amino acids does not actually select them in the program. To further clarify, checking residues in the docking box dialogue doesn't change the binding box in any way, and checking residues in the flexible sidechain dialogue doesn't add them to the list of selected flexible residues displayed at left. The following lines are then displayed in the black coding window:

prody.atomic.select.SelectionError: An invalid selection string is encountered:
u'chid resnum 421'
^chid must be followed by values

We circumvented this by manually entering center and size parameters for the docking box, and by typing the residue numbers directly into the flexible residues line on the left side of the AGFR interface window. However, the latter operation doesn't change the right-side gray check mark in the lower left portion of the window to a green check mark as it does in the tutorial; it just stays gray. We can compute pockets, but then when we generate maps, we get the following line in the black coding window:

File "C:\Program Files (x86)\MGLTools2-1.0\lib\site-packages\ADFR\utils\makeGR
ids.py", line 39, in splitFlexRes
for atom in sideChainAtoms:
TypeError: 'NoneType' object is not iterable

and no maps are generated. I tried running AGFR with the tutorial receptor and also generated a .pdbqt of rhodopsin (1F88) and both of those worked perfectly well, which leads me to believe that something about the I-TASSER output pdb->.pdbqt is not compatible with the AGFR program. I thought 'chid' might stand for 'chain ID'; I-TASSER doesn't assign a chain ID as it lacks a quaternary structure function, so I tried assigning an arbitrary "A:HIS421,TRP389" in the flexible residues line and it said that "residue 421 was not found in chain A; residue 389 was not found in chain A".

Any ideas? We'd really like to try out the ADFR program if we can get it to work with our receptor models! Any advice is appreciated, thank you!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
POWERED_BY
Translated by MaĆ«l Soucaze © 2009 phpBB.fr