The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Fri Apr 20, 2018 6:26 pm

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Mon Jun 29, 2015 11:41 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Mon Jun 29, 2015 11:37 am
Posts: 1
Dear autodocktools users

I installed following programs on windows:

First:python-2.7.3
Second:autodocksuite-4.2.5.1-i86Windows
third:mgltools_win32_1.5.6_Setup
fourth:autodock_vina_1_1_2_win32

After the installation, I used autodocktools 3 or 4 times.

When I start AutoDockTools for the fifth time, I encountered
with following message in python shell windows:
------------------------------------------------------------------------------------------------
Python 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)] on win32
Type "copyright", "credits" or "license()" for more information.

****************************************************************
Personal firewall software may warn about the connection IDLE
makes to its subprocess using this computer's internal loopback
interface. This connection is not visible on any external
interface and no data is sent to or received from the Internet.
****************************************************************

IDLE 1.2.2 ==== No Subprocess ====
>>> Traceback (most recent call last):
File "C:\Program Files\MGLTools-1.5.6\lib\site-packages\AutoDockTools\__init__.py", line 433, in runADT
title=title, withShell= not interactive, verbose=False, gui=gui)
File "C:\Program Files\MGLTools-1.5.6\lib\site-packages\Pmv\moleculeViewer.py", line 843, in __init__
trapExceptions=trapExceptions)
File "C:\Program Files\MGLTools-1.5.6\lib\site-packages\ViewerFramework\VF.py", line 505, in __init__
self.userpref.loadSettings()
File "C:\Program Files\MGLTools-1.5.6\lib\site-packages\mglutil\preferences.py", line 138, in loadSettings
self.set(key, value)
File "C:\Program Files\MGLTools-1.5.6\lib\site-packages\mglutil\preferences.py", line 107, in set
cb(name,oldValue, value)
File "C:\Program Files\MGLTools-1.5.6\lib\site-packages\ViewerFramework\VF.py", line 732, in startupDirPref_cb
root = self.setUserPreference.form.root
AttributeError: SetUserPreference instance has no attribute 'form'
hit enter to continue
------------------------------------------------------------------------------------------------
First time I enconutered with this problem, I uninstalled all of above programs. Then I reinstalled them.

Unfortunately, after 4 times using of autodocktools, again, I encontered the same problem.

Is not my installation way correct?

What is the reason of this problem?

Is there a problem about python?

Any help will highly appreciated.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
POWERED_BY
Translated by MaĆ«l Soucaze © 2009 phpBB.fr