The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Sat Jul 21, 2018 11:43 am

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Bug in latest version?
PostPosted: Wed Aug 14, 2013 3:26 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Mon Jul 29, 2013 12:10 am
Posts: 8
I just upgraded to the latest release of ePMV for cinema 4d (0.5.165) and it no longer works when I upload my own .pdb file. I've checked to make sure the files are intact. When I upload I basically just get a null object with some null children without any shapes or meshes. Can this be fixed? thanks!


Top
 Profile  
 
PostPosted: Wed Aug 14, 2013 3:31 am 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi,
sorry about that and thanks for the report. Could send me the content of the console it may help see what could be the problem. Meanwhile I will check if I can reproduce the problem.
Is it the case for any molecule ? Did you try to display some representation like MSMS ? what happen then ?

Ludo


Top
 Profile  
 
PostPosted: Wed Aug 14, 2013 6:10 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Mon Jul 29, 2013 12:10 am
Posts: 8
the plugin works fine if I do 'fetch pdb' or execute one of the preset python scripts. It only has problems when I upload my own .pdb file (any .pdb file). Here's the console output:

not adt read /Users/path/to/file/st_02.pdb
.............loadMolecule..................
read <Protein instance> st_02 with 1 MolKit.protein.Chain
0
Failed to save recent files
[Errno 2] No such file or directory: '/Users/volvox/.mgltools/1.5.6rc3/Pmv/recent.pkl'
('startingRepresentation', 'secondary structure')
('getDsInfo_cb st_02', <type 'str'>)
('st_02', <Protein instance> st_02 with 1 MolKit.protein.Chain)
no secondary structure set for chain: !
menu 1054


Top
 Profile  
 
PostPosted: Wed Aug 14, 2013 4:24 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi,
epmv was not able to recognize any secondary structure but read the file
('st_02', <Protein instance> st_02 with 1 MolKit.protein.Chain)
no secondary structure set for chain: !

Could you try to read st_02, then see if appears in the current mol pull down menu
then check Lines. The default representation when you load a PDB is the ribbon, so if epmv failed to recognize them nothing will appear in the viewport but you can still try to view the atoms or the surface.

Could you also try to look in the preference and check Force PROSS (http://roselab.jhu.edu/utils/pross.html) which will compute the secondary structure information before loading the pdb.

Ludo


Top
 Profile  
 
PostPosted: Thu Aug 15, 2013 5:02 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Mon Jul 29, 2013 12:10 am
Posts: 8
thanks, i think it was working all along and i just didn't click on atoms/sticks or zoom in once I loaded the file. Sorry for the false alarm and I appreciate the quick troubleshooting. Great work on the software!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
POWERED_BY
Translated by MaĆ«l Soucaze © 2009 phpBB.fr