The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Thu Apr 26, 2018 5:36 am

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Sat Apr 20, 2013 10:43 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Apr 20, 2013 9:34 pm
Posts: 5
Hi!

I have the problem with upy_autoPack_plugin in Maya 2012 when I was trying to load it in Plug-in Manager.

Image

As you can see on the picture the shelf is empty as well.

I tried to update, but unfortunately no result

Help me please to fix this problem


P.S I can't download AutoFill from http://www.autopack.org/install/update


It wrote (404. That’s an error.

The requested URL /files/ was not found on this server
.)


Attachments:
File comment: upy_autoPack_plugin in Maya 2012
upy_autoPack_plugin.jpg
upy_autoPack_plugin.jpg [ 238.05 KiB | Viewed 6655 times ]
Top
 Profile  
 
PostPosted: Mon Apr 22, 2013 6:17 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi,

sorry to hear you didnt get it running.
Firstly the installer on windows only support maya 2013. So for Maya 2012 you have to follow the manual installation. Which is basically copying folder under the maya plugin folder.
See here :http://www.autopack.org/install/maya-installation

If you have done the manual installation, send me the content of the console windows which should tell the error/problem why epmv/autopack are not loaded.

Ludovic


Top
 Profile  
 
PostPosted: Mon Apr 22, 2013 9:42 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Apr 20, 2013 9:34 pm
Posts: 5
I added screenshot and Maya txt. from script editor.

It's weird, because even if it shown as loaded the shelf is still empty



P.S

I've done step by step like on this page (http://www.autopack.org/install/maya-installation)

I added screenshot AutoFill Error as well


Attachments:
autofill_error404.jpg
autofill_error404.jpg [ 230.73 KiB | Viewed 6650 times ]
Erorr loading-upy_autoPack_plugin.py [6.17 KiB]
Downloaded 287 times
loaded upy-Empty shelf.jpg
loaded upy-Empty shelf.jpg [ 189.74 KiB | Viewed 6650 times ]
Top
 Profile  
 
PostPosted: Mon Apr 22, 2013 11:15 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Ok I can see that both plugin are actually loaded, but dont show up in the shelf.
That mean the shelf is not configure correctly.
Verify that :
- you have the icons autoCell.tif and pmv.tif under 2013-x64/prefs/icons
- shelf_uPy.mel in 2013-x64/prefs/shelves

if you to test if epmv is correctly installed and that it is only a problem of shelve, try to type theses commands in the console in python mode. This is what actually does the shelf.
Code:
import maya
#ePMV
maya.cmds.ePMV()
#epmv = maya.mv['epmv'] #if you want to retrieve the epmv object and do some scripting using epmv.
#autoPACK
maya.cmds.AutoFill()


Top
 Profile  
 
PostPosted: Tue Apr 23, 2013 2:15 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Apr 20, 2013 9:34 pm
Posts: 5
Yes I have the Icons and shelf_uPy.mel but it doesn't show up

C:\Users\RSky\Documents\Maya\2012-x64\prefs\icons
C:\Users\RSky\Documents\Maya\2012-x64\prefs\shelves

Unfortunately shelf still empty and I don't know how load the icons

All the time use this script?


Attachments:
Emptyshelf.jpg
Emptyshelf.jpg [ 171.53 KiB | Viewed 6646 times ]
Top
 Profile  
 
PostPosted: Tue Apr 23, 2013 4:09 am 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
that is strange,
here are your solution :
- create a shelf yourself, not as difficult, I think there is some tutorial for shelf with python command.
- delete 2012-x64 folder completely, restart maya which will recreate a fresh folder for you (you do that if you dont have other important plugins installed.). Then recopy there the plugin folder as describe in the manual instruction.


L


Top
 Profile  
 
PostPosted: Tue Apr 23, 2013 6:26 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Apr 20, 2013 9:34 pm
Posts: 5
It's works!!!

Thank you very much!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
POWERED_BY
Translated by Maël Soucaze © 2009 phpBB.fr