The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Tue Jan 23, 2018 3:45 pm

All times are UTC




Post new topic Reply to topic  [ 11 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Sat Mar 16, 2013 1:03 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Wed Feb 06, 2013 11:17 pm
Posts: 6
No, no luck. I still can't get modeller to work and do what is in the video on this page; http://epmv.scripps.edu/extensions/modeller

Ludo i must have installed it wrong, or something like that. I repeated the exact same installation on another different computer, i installed Maya 2012 and Modeller, and Modeller doesn't work on that computer either???? Both of the computers are windows xp machines. And the modeller extension won't work on either machine. So i must be doing something wrong during installation. Funny, but some of the other extensions don't work either???
So i will write out the exact procedure and maybe you can spot where i am going wrong;

This is what i am doing;
---------
1. I install Maya 2012 on windows xp machine.

2. I install Modeller 9.11 into C:\Program Files\Modeller9.11

3. I start installing ePMV following the instructions on this page; http://www.autopack.org/install/maya-installation

3. I use "Option 2", the manual install, so i can install the windows 32 bit version

4. I download this file and extract it to my desktop; http://upy.googlecode.com/files/uPy-aP- ... _0_man.zip

5. The instructions say;
"The archive contains a plug-ins folder with an epmv_maya_plugin.py file and a MGLToolsPckgs folder, place these items into either/both folders below: C:\Users\userName\Documents\maya\2012\plug-ins\

6. But my Maya 2012 folder does not have a folder called "plug-ins", so i create a new folder called "plug-ins" like this;
C:\Documents and Settings\User\My Documents\maya\2012\plug-ins

7. And i put 3 items into that "plug-ins" folder like this;
C:\Documents and Settings\User\My Documents\maya\2012\plug-ins\MGLToolsPckgs
C:\Documents and Settings\User\My Documents\maya\2012\plug-ins\epmv_maya_plugin.py
C:\Documents and Settings\User\My Documents\maya\2012\plug-ins\upy_autoPack_plugin.py

8. Just to clarify, the "MGLToolsPckgs" folder is the full 131 megabites of stuff

9. The instructions also say to put the same stuff into here;
C:\Documents and Settings\User\My Documents\maya\2012-x64\plug-ins\

10. But i don't have a folder "2012-x64" so i skip that!

11. Then the instructions say;
"The archive also contains a prefs folder with icons and shelves folders, place these two into either/both folders (replacing them), or move their contents into the existing folders to retain your original prefs:
1.C:\Users\userName\Documents\maya\2012\prefs\

12. So i install the two icons into;
C:\Documents and Settings\User\My Documents\maya\2012\prefs\icons

13. And i install the file "shelf_uPy.mel" into the shelves folder;
C:\Documents and Settings\User\My Documents\maya\2012\prefs\shelves\shelf_uPy.mel
Its in that folder with about 12 other shelf files.

14. Note; This next bit is not in the instructions, but i do it anyway. It just seemed like the right thing to do???

15. The zipped archive i downloaded also contains a file called "pluginPrefs.mel", so i open the file with notepad to see what is in the file.

16. I see that my Maya installation also has a file called "pluginPrefs.mel", so i open it with notepad and compare the two files.
The Maya "pluginPrefs.mel" file is here;
C:\Documents and Settings\User\My Documents\maya\2012\prefs\pluginPrefs.mel

17. The zipped archive i downloaded has these lines;
evalDeferred("autoLoadPlugin(\"\", \"epmv_maya_plugin.py\", \"epmv_maya_plugin\")");
evalDeferred("autoLoadPlugin(\"\", \"upy_autoPack_plugin.py\", \"upy_autoPack_plugin\")");

18. So i copy those two lines of instructions and i paste them into the "pluginPrefs.mel" file in the Maya2012 prefs folder. I paste them into this file;
C:\Documents and Settings\User\My Documents\maya\2012\prefs\pluginPrefs.mel

19. So now that file looks like this;
Code:
//Maya Preference 2012 (Release 1)
//
//
evalDeferred("autoLoadPlugin(\"\", \"OpenEXRLoader\", \"OpenEXRLoader\")");
evalDeferred("autoLoadPlugin(\"\", \"DirectConnect\", \"DirectConnect\")");
evalDeferred("autoLoadPlugin(\"\", \"mayaHIK\", \"mayaHIK\")");
evalDeferred("autoLoadPlugin(\"\", \"ikSpringSolver\", \"ikSpringSolver\")");
evalDeferred("autoLoadPlugin(\"\", \"Mayatomr\", \"Mayatomr\")");
evalDeferred("autoLoadPlugin(\"\", \"decomposeMatrix\", \"decomposeMatrix\")");
evalDeferred("autoLoadPlugin(\"\", \"tiffFloatReader\", \"tiffFloatReader\")");
evalDeferred("autoLoadPlugin(\"\", \"VectorRender\", \"VectorRender\")");
evalDeferred("autoLoadPlugin(\"\", \"mayaCharacterization\", \"mayaCharacterization\")");
evalDeferred("autoLoadPlugin(\"\", \"rotateHelper\", \"rotateHelper\")");
evalDeferred("autoLoadPlugin(\"\", \"epmv_maya_plugin.py\", \"epmv_maya_plugin\")");
evalDeferred("autoLoadPlugin(\"\", \"MayaMuscle\", \"MayaMuscle\")");
evalDeferred("autoLoadPlugin(\"\", \"Substance\", \"Substance\")");
evalDeferred("autoLoadPlugin(\"\", \"OneClick\", \"OneClick\")");
evalDeferred("autoLoadPlugin(\"\", \"upy_autoPack_plugin.py\", \"upy_autoPack_plugin\")");
evalDeferred("autoLoadPlugin(\"\", \"fbxmaya\", \"fbxmaya\")");
evalDeferred("autoLoadPlugin(\"\", \"ik2Bsolver\", \"ik2Bsolver\")");


20. Now i follow the modeller installation page instructions; http://epmv.scripps.edu/extensions/modeller

21`. The modeller page says;
"edit patho_ePMV/extension/liste.txt to provide the pathtoModeller modlib library!

22. So i open this file;
C:\Documents and Settings\User\My Documents\maya\2012\plug-ins\MGLToolsPckgs\ePMV\extension\liste.txt

22. And i add this exact text;
modeller C:\Program Files\Modeller9.11\modlib
Because that is where modeller is installed!

23. I start the Maya software and open ePMV inside Maya

24. I edit my ePMV preferences, and i tick the box for "Extensions->Use Modeller", and i click the "apply and close" button to save the preferences.

25. Then in ePMV, i get the 1CRN protein model from the PDB. I un-tick the ribbons representation of the model and i display the "Atoms" model instead.

26. I select modeller from the extensions menu and it opens the modeller window.

27. I tick the "real time" tick box, and nothing happens. No error or nothing! No movement.

28. I change from "mini" to "md" and i get the error;
# Error: AttributeError: Protein instance has no attribute 'mdl' #

Ludo can you spot what i am doing wrong?

Thanks,
John.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
POWERED_BY
Translated by Maël Soucaze © 2009 phpBB.fr