The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Mon Dec 18, 2017 10:17 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sat Aug 11, 2012 5:20 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Aug 11, 2012 4:53 pm
Posts: 3
Dear Molecular Graphics Laboratory and Community,

Thank you for your efforts in developing ePMV and related molecular visualization software as well as making the source code of it available. The result seems to be excellent.
Having downloaded the current standalone installer of ePMV Blender for Windows XP, I get an error message whenever I try to start up ePMV in Blender by pressing the ePMV button in the upper right corner:
Code:
Traceback (most recent call last):
  File "C:\blender\2.62\scripts\addons\epmv_blender_plugin.py", line 100, in execute
    epmvgui.setup(rep="epmv",mglroot=MGL_ROOT,host='blender25')
  File "C:\blender/MGLToolsPckgs\ePMV\epmvGui.py", line 1207, in setup
    epmv = ePMV.epmv_start(self.host,debug=0)
  File "C:\blender/MGLToolsPckgs\ePMV\__init__.py", line 46, in epmv_start
    return adaptor(gui=gui,debug=debug)
  File "C:\blender/MGLToolsPckgs\ePMV\blender\v25\blenderAdaptor.py", line 36, in __init__
    epmvAdaptor.__init__(self,mv,host='blender25',debug=debug)
  File "C:\blender/MGLToolsPckgs\ePMV\epmvAdaptor.py", line 395, in __init__
    self.addADTCommands()
  File "C:\blender/MGLToolsPckgs\ePMV\epmvAdaptor.py", line 560, in addADTCommands
    from AutoDockTools.autoanalyzeCommands import ADGetDLG,StatesPlayerWidget,ShowAutoDockStates
  File "C:\blender/MGLToolsPckgs\AutoDockTools\autoanalyzeCommands.py", line 119, in <module>
    from AutoDockTools.Docking import Docking, FoxResultProcessor
  File "C:\blender/MGLToolsPckgs\AutoDockTools\Docking.py", line 859, in <module>
    from bhtree import bhtreelib
  File "C:\blender/MGLToolsPckgs\bhtree\__init__.py", line 1, in <module>
    from .bhtreelib import *
  File "C:\blender/MGLToolsPckgs\bhtree\bhtreelib.py", line 26, in <module>
    _bhtreelib = swig_import_helper()
  File "C:\blender/MGLToolsPckgs\bhtree\bhtreelib.py", line 22, in swig_import_helper
    _mod = imp.load_module('_bhtreelib', fp, pathname, description)
ImportError: DLL load failed: Indicated module was not found.

location:<unknown location>:-1

As far as I can see, the files exist.
Furthermore, I have already tried to put the MGLToolsPckgs folder in the Windows root directory (C:\), but this just made the ePMV menu disappear entirely from Blender.
Could anyone of you point me towards additional diagnostics I could run in order to pin down the problem?

Thanks in advance,
Ted


Top
 Profile  
 
PostPosted: Mon Aug 13, 2012 10:03 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi,

is it the 64bits version that you tried ? or the 32bits ?
If it was the 64bits, try the 32bits while I am trying to reproduce the error.

Ludovic


Top
 Profile  
 
PostPosted: Tue Aug 14, 2012 8:48 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Aug 11, 2012 4:53 pm
Posts: 3
Thanks a lot for your reply.

It was the 32bit version that I tried (and which is of course marked to be experimental). Version 2.49 works perfectly on Windows XP.

In the meantime I have used the 64bit version on Mac OS X, which work nicely, and the 32bit as well as the 64bit linux versions on Debian which lament
Code:
"./blender: error while loading shared libraries: libfreetype.so.6: cannot open shared object file: No such file or directory".

The problem here is that I don't have administrative rights to install libfreetype.
I will let you know if I will have found some workaround for it.


Top
 Profile  
 
PostPosted: Tue Aug 14, 2012 9:16 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Aug 11, 2012 4:53 pm
Posts: 3
The problem with libfreetype was that it has been part of a libc compiled for 32bit, which does of course not work with the 64bit version of blender.
Using the 32bit version of epmv-blender and running
Code:
chmod u+x setenvTk.sh
./setenvTk.sh

everything works fine.


Top
 Profile  
 
PostPosted: Tue Aug 14, 2012 3:34 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
I am glad you found a work around and thanks for sharing it with us.
Let me know if you encounter any other issues.

Ludovic


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
POWERED_BY
Translated by MaĆ«l Soucaze © 2009 phpBB.fr