The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Mon Dec 18, 2017 10:11 pm

All times are UTC




Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Thu Mar 15, 2012 7:29 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Thu Mar 15, 2012 7:22 pm
Posts: 2
I tried to launch ePMV from Maya by double clicking the ePMV icon on the Custom Panel but I get the error below.

AttributeError: 'module' object has no attribute 'ePMV'

I do not have alot of computer background. It took me awhile just to get to this point. I am very excited to review this program and use it for my project. Please help.


Top
 Profile  
 
PostPosted: Thu Mar 15, 2012 8:53 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
hi,
thanks for trying ePMV, and sorry it didnt work.
can you verify if the plugin is actually loaded in the plugin manager.
also, can you provide the full content of the consol/script editor windows..

thanks

Ludo


Top
 Profile  
 
PostPosted: Thu Mar 15, 2012 11:52 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Thu Mar 15, 2012 7:22 pm
Posts: 2
I really appreciate your quick response. I loaded it in using the download manager. Now, it's time to play around with it and see for myself the cool things it can do.

Thank you!


Top
 Profile  
 
PostPosted: Mon Mar 19, 2012 3:52 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi,

I am glad you get it working. Don't hesitate to post any rendering experiments, comments and bugs !

Ludovic


Top
 Profile  
 
PostPosted: Thu Oct 25, 2012 8:51 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Thu Oct 25, 2012 8:42 pm
Posts: 1
I am having this issue as well.
I was able to get it to run once properly though, but now I can not get it to work. The icon is up in the custom doc and it is set to auto-load and loaded.

Here is the error information:

commandPort -securityWarning -name commandportDefault;
updateRendererUI;
PhysX factory settings loaded.
updateRendererUI;
import maya
maya.cmds.ePMV()
epmv = maya.mv['epmv']
self = epmv.mv

# Error: AttributeError: 'module' object has no attribute 'ePMV' #

I am using Windows 7 and Maya 2012.

Thanks


Top
 Profile  
 
PostPosted: Thu Oct 25, 2012 9:24 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi,

is it 32 or 64 bits ?
you need both auto load and load check box checked.
also in the terminal windows could you check the show stack trace in the History menu, and then click again on the load checkbox of the plugin in the plugin manager....This should show more information on the error.

also sometimes , just after loading, you need to wait some second before running the plugin...


Ludo


Attachments:
File comment: History->stack trace
Screen shot 2012-10-25 at 2.23.35 PM.png
Screen shot 2012-10-25 at 2.23.35 PM.png [ 44.88 KiB | Viewed 10759 times ]
Top
 Profile  
 
PostPosted: Tue Nov 20, 2012 10:43 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Tue Nov 20, 2012 10:14 am
Posts: 2
Hi,

I'm having the same problem on Maya 2013. This is the script output when I check the run box in the plug-in manager:

Code:
M:\pc\Dokumenter\maya\2013-x64\plug-ins\MGLToolsPckgs
M:\pc\Dokumenter\maya\2013-x64\plug-ins\
M:\pc\Dokumenter\maya\2013-x64\plug-ins\\MGLToolsPckgs\ePMV\images\icons\
ePMV
('getUIClass ', 'maya')
// Error: line 1: cannot import name viewerConst
# Traceback (most recent call last):
#   File "M:/pc/Dokumenter/maya/2013-x64/plug-ins/epmv_maya_plugin.py", line 104, in <module>
#     from ePMV import epmvGui
#   File "M:\pc\Dokumenter\maya\2013-x64\plug-ins\/MGLToolsPckgs\ePMV\epmvGui.py", line 22, in <module>
#     import ePMV.pmv_dev.APBSCommands_2x as APBS
#   File "M:\pc\Dokumenter\maya\2013-x64\plug-ins\/MGLToolsPckgs\ePMV\pmv_dev\APBSCommands_2x.py", line 66, in <module>
#     from Pmv.mvCommand import MVCommand
#   File "M:\pc\Dokumenter\maya\2013-x64\plug-ins\/MGLToolsPckgs\Pmv\mvCommand.py", line 18, in <module>
#     from ViewerFramework.VFCommand import Command, CommandGUI, \
#   File "M:\pc\Dokumenter\maya\2013-x64\plug-ins\/MGLToolsPckgs\ViewerFramework\VFCommand.py", line 39, in <module>
#     from DejaVu.Geom import Geom
#   File "M:\pc\Dokumenter\maya\2013-x64\plug-ins\/MGLToolsPckgs\DejaVu\__init__.py", line 198, in <module>
#     from Viewer import Viewer
#   File "M:\pc\Dokumenter\maya\2013-x64\plug-ins\/MGLToolsPckgs\DejaVu\Viewer.py", line 50, in <module>
#     from DejaVu import viewerConst
# ImportError: cannot import name viewerConst //
// Warning: line 1: Failed to run file: M:/pc/Dokumenter/maya/2013-x64/plug-ins/epmv_maya_plugin.py //
// Error: line 1:  (epmv_maya_plugin) //


If I try to open the plug-in from the customs bar, I get this output:

Code:
import maya
maya.cmds.ePMV()
epmv = maya.mv['epmv']
self = epmv.mv

# Error: 'module' object has no attribute 'ePMV'
# Traceback (most recent call last):
#   File "<maya console>", line 2, in <module>
# AttributeError: 'module' object has no attribute 'ePMV' #


Top
 Profile  
 
PostPosted: Tue Nov 20, 2012 6:27 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi the plugin for maya 2013 in windows is not actually stable. I didn't had the time to correct it yet.
I am aware of theses bugs and had the solution...so please be patient, and as soon as the package will be ready I will post the link.

Thanks
Ludovic


Top
 Profile  
 
PostPosted: Tue Nov 20, 2012 8:47 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Tue Nov 20, 2012 10:14 am
Posts: 2
Thank you! I'll try to be patient! The plug-in looks great!


Top
 Profile  
 
PostPosted: Tue Dec 18, 2012 4:34 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
you can try our last installer for maya on windows:
http://www.autopack.org/install/maya-installation
after installation try to update (Help->check for update)

L


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
POWERED_BY
Translated by MaĆ«l Soucaze © 2009 phpBB.fr