The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Wed May 23, 2018 3:12 pm

All times are UTC




Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Mon Oct 03, 2011 9:29 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Mon Oct 03, 2011 8:51 am
Posts: 2
Hi there

I'm having trouble gettin ePMV and Blender installed and running - would be grateful for help and advice

I'm running Win 7 Pro 64bit

Firstly I've tried the standalone installers - using the links on http://epmv.scripps.edu/download-install-free/perhost I installed Python2.6.6_64 then downloaded empv-blender-2.49b-windows64_VC and ran this Blender

Blender loads fine, within Blender I click Script->System->ePMV and... Blender vanishes.

So then I've tried the manual install sequence:

I've downloaded MGLTools from the eMPV site (not MGL Tools site, as instructed), extracted into C:MyTools, extracted the ePMV and pyubic folders into the MGLTools folder, opened Blender (downloaded from the link in Step 3 on http://epmv.scripps.edu/download-instal ... stallation), loaded install_plugin.py and run it, and it highlights the line

from ePMV, installer import Installer

as being incorrect

I'm not sure what to do next

I really want to get ePMV working in Blender

All help appreciated

Thanks

jON


Top
 Profile  
 
PostPosted: Mon Oct 03, 2011 4:47 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi jon,
first of all sorry you didnt get it working in 64bits. Its quite an early vesion.
So could you try the 32bit version from http://epmv.scripps.edu/download-instal ... nder-2.49b
this require also Python2.6.6. so you may have to remove the previous version http://www.python.org/ftp/python/2.6.6/python-2.6.6.msi

I will do some more test on the 64bits see if something is wrong.

Ludovic


Top
 Profile  
 
PostPosted: Mon Oct 03, 2011 5:13 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
I just check it and its seems too work on the windows computer I am using,
if you cant get the 32bits version working, contact me directly
autin_at_scripps.edu

Ludovic


Top
 Profile  
 
PostPosted: Mon Oct 03, 2011 8:05 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Mon Oct 03, 2011 8:51 am
Posts: 2
Thanks for your efforts

I've installed the 32bit version as you suggested, and have it working (I'm about to try using it...)

It gave me the R6034 runtime error during load that's listed in thr Troubleshooting guide on the website, but clicking OK (as it says) takes me to the program anyway

Thanks again (here's hoping it now runs fine)

By the way, if you or anyone else felt like writing a version of ePMV for Softimage I would be REALLY grateful

jON


Top
 Profile  
 
PostPosted: Mon Oct 03, 2011 8:44 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
HI,

Ok let me know if you encounter any other problem...should be fine for most of the features...

Quote:
By the way, if you or anyone else felt like writing a version of ePMV for Softimage I would be REALLY grateful

Well there is some effort from the Blur company to provide Python binding for 3dsMax and softimage. So we could imagine that epmv could be port to theses software as well, but this is probably not gonna happen any soon, except if as you else someone else give it a try. You can still use C4D or maya.

Ludovic


Top
 Profile  
 
PostPosted: Mon Nov 21, 2011 9:37 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Mon Nov 21, 2011 9:31 pm
Posts: 2
Hi

I am also running into trouble setting up ePMV in Blender. I am running a 32-bit Linux. Blender was installed via the OS's package manager is running fine on its own. MGLTools have been installed as indicated in the instructions, and the ePMV folder has been extracted into MGLTools-1.5.6rc2. When i try to run the install_plugin.py script, an error occurs in the console such as
Code:
/install_plugin.py
Traceback (most recent call last):
  File "/install_plugin.py", line 44, in <module>
ImportError: No module named Blender


Am I missing something?


Top
 Profile  
 
PostPosted: Tue Nov 22, 2011 2:35 am 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
hi,

well is for blender 2.49 or 2.5. If ts 2.5 we dont support it yet on linux.
if its blender 2.49b you need to run the python script from the text editor inside blender.
Furthermore I am currently preparing a standalone package for linux, you will just have to unzip and run blender and it will have the plugin directly in it.
you can try to install it manually if you feel comfortable with python. The installation simply copy the python plugin file into the user script folder of blender.
Namely, ePMV/blender249/plugin/epmv_blender_plugin.py in .blender/scripts/.

I will make a post once I will have a standalone for linux

Ludo


Top
 Profile  
 
PostPosted: Thu Nov 24, 2011 12:26 am 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
I added a linux package for epmv. Its came with blender2.48b, python2.5 and epmv.
just download http://mgldev.scripps.edu/projects/ePMV ... x-py25.zip
unzip
run epmv-blender
if ePMV dont appear in Script->System-> ePMV
go in the preference and change the script directory to blender-2.49/.blender/script

Ludovic


Top
 Profile  
 
PostPosted: Thu Nov 24, 2011 2:32 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Mon Nov 21, 2011 9:31 pm
Posts: 2
Hi Ludovic

Thank you very much. I will only be able to try it out on the weekend (on my home computer). I will let you know how it worked.

Thanks again
Reto


Top
 Profile  
 
PostPosted: Thu Nov 24, 2011 4:39 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
You may also encounter a problem at launching. There is a windows for registration that may popup off screen...
I am trying to fix this.

Ludo


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
POWERED_BY
Translated by Maël Soucaze © 2009 phpBB.fr