The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Thu Apr 24, 2014 9:04 pm

All times are UTC




Post new topic Reply to topic  [ 19 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Loading EM maps
PostPosted: Thu Aug 11, 2011 3:12 pm 
Offline
Micromolar User
Micromolar User
User avatar

Joined: Sun Aug 07, 2011 4:10 am
Posts: 18
Graham wrote:
Very quickly though, I'm not sure what LONG time means in your world.
It takes <9 seconds to build the initial model after selecting emd_1097.ccp4 file with ePMV in Cinema4D on my 1st generation Intel Mac (default thread).... This may be different for Blender 2.49.
G


9 secs? I don't know whether I should laugh loudly or cry weeping and sobbing. It took my computer 75, wait for it, minutes(!) to open my map; yes, more than an hour (and I had to open it again and time it to write this)! I must have a very patient personality, ha? :) And looks like I should have put many more 'o's to my looong :)


Top
 Profile  
 
 Post subject: Re: Loading EM maps
PostPosted: Thu Aug 11, 2011 3:17 pm 
Offline
Micromolar User
Micromolar User
User avatar

Joined: Sun Aug 07, 2011 4:10 am
Posts: 18
ludo wrote:
I update the pacakge for windows, you can get it... Let me know if you encounter any other problem.
Ludo


I downloaded and unzipped it as I did with the previous one, but unlike that one, this one is no go. It says "Python script error" and this is what was in the terminal.

Code:
Compiled with Python version 2.6.6.
Checking for installed Python... got it!
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "C:\Users\jacklab\epmv-blender-2.49b-windows32\.blender\scripts\epmv_blen
der_plugin.py", line 74, in <module>
    from ePMV import epmvGui
  File "C:\Users\jacklab\epmv-blender-2.49b-windows32/MGLToolsPckgs\ePMV\epmvGui
.py", line 19, in <module>
    from ePMV.APBSCommands import APBSgui
  File "C:\Users\jacklab\epmv-blender-2.49b-windows32/MGLToolsPckgs\ePMV\APBSCom
mands.py", line 65, in <module>
    from Pmv.mvCommand import MVCommand
  File "C:\Users\jacklab\epmv-blender-2.49b-windows32/MGLToolsPckgs\Pmv\mvComman
d.py", line 18, in <module>
    from ViewerFramework.VFCommand import Command, CommandGUI, \
  File "C:\Users\jacklab\epmv-blender-2.49b-windows32/MGLToolsPckgs\ViewerFramew
ork\VFCommand.py", line 39, in <module>
    from DejaVu.Geom import Geom
  File "C:\Users\jacklab\epmv-blender-2.49b-windows32/MGLToolsPckgs\DejaVu\__ini
t__.py", line 198, in <module>
    from Viewer import Viewer
  File "C:\Users\jacklab\epmv-blender-2.49b-windows32/MGLToolsPckgs\DejaVu\Viewe
r.py", line 45, in <module>
    from opengltk.OpenGL import GL
  File "C:\Users\jacklab\epmv-blender-2.49b-windows32/MGLToolsPckgs\opengltk\Ope
nGL\GL.py", line 7, in <module>
    from opengltk.extent._gllib import *
ImportError: DLL load failed: A dynamic link library (DLL) initialization routin
e failed.


Top
 Profile  
 
 Post subject: Re: Loading EM maps
PostPosted: Thu Aug 11, 2011 3:45 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Ok,
Sorry about that,
I will prepare another one that hopefully will work. This is due to the complexity of compilation and lbrary linking under windows....
In the meantime, you can copy the MGLToolsPckgs/UTPacakges directory from the new blender folder, to the previous working one.
This module handle the isocontouring, thus you should get the performance improvement...

Ludovic


Top
 Profile  
 
 Post subject: Re: Loading EM maps
PostPosted: Thu Aug 11, 2011 4:40 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Can you try to instal the microsoft redistribuable, it may fix the problem..
http://www.microsoft.com/download/en/de ... g=en&id=29


Top
 Profile  
 
 Post subject: Re: Loading EM maps
PostPosted: Thu Aug 11, 2011 6:16 pm 
Offline
Micromolar User
Micromolar User
User avatar

Joined: Sun Aug 07, 2011 4:10 am
Posts: 18
ludo wrote:
Can you try to instal the microsoft redistribuable, it may fix the problem..
http://www.microsoft.com/download/en/de ... g=en&id=29


I installed this, but still getting the same errors.


Top
 Profile  
 
 Post subject: Re: Loading EM maps
PostPosted: Thu Aug 11, 2011 9:49 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
I am sorry to hear that it took you an hour ti get your map..
so I finally got a working version (I just test it on vista 64bits), the problem was as I though some compilation flag not properly set, thanks to the MGL dev team, I was able to recompile the part that was giving problem.
you can find the package here:
http://mgldev.scripps.edu/projects/ePMV ... s32_VC.zip

and I hope this one will actually work and solve the map reading problem....

Ludovic
PS: you can contact me directly : autin_at_scripps.edu


Top
 Profile  
 
 Post subject: Re: Loading EM maps
PostPosted: Fri Aug 12, 2011 2:10 pm 
Offline
Micromolar User
Micromolar User
User avatar

Joined: Sun Aug 07, 2011 4:10 am
Posts: 18
ludo wrote:
I am sorry to hear that it took you an hour ti get your map..
so I finally got a working version (I just test it on vista 64bits), the problem was as I though some compilation flag not properly set, thanks to the MGL dev team, I was able to recompile the part that was giving problem.
you can find the package here:
http://mgldev.scripps.edu/projects/ePMV ... s32_VC.zip
and I hope this one will actually work and solve the map reading problem....
Ludovic
PS: you can contact me directly : autin_at_scripps.edu


Thanks for the rapid update Ludo. This one works, has comparable speed to the Linux version, and I do not need to open a PDB first. Nicely done.


Top
 Profile  
 
 Post subject: Re: Loading EM maps
PostPosted: Fri Aug 12, 2011 3:09 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Quote:
Thanks for the rapid update Ludo. This one works, has comparable speed to the Linux version, and I do not need to open a PDB first. Nicely done.


Ok great! glad you get it finally working...if you have some screenshot, comment, etc..feel free to contact us, there is also a thread on a forum for posting video and render.

Ludovic


Top
 Profile  
 
 Post subject: Re: Loading EM maps
PostPosted: Fri Aug 12, 2011 5:21 pm 
Offline
Micromolar User
Micromolar User
User avatar

Joined: Sun Aug 07, 2011 4:10 am
Posts: 18
ludo wrote:
Ok great! glad you get it finally working...if you have some screenshot, comment, etc..feel free to contact us, there is also a thread on a forum for posting video and render.


I sure will post my renders, assuming I will learn enough Blender to produce something worth posting. Oh, another 'minor' detail: We need to publish the structure first ;)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
POWERED_BY
Translated by Maël Soucaze © 2009 phpBB.fr