The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Sun Jun 24, 2018 8:55 am

All times are UTC




Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Blender install issue
PostPosted: Sat Mar 19, 2011 7:36 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Mar 19, 2011 6:31 pm
Posts: 8
Dear Ludovic,

I try to install ePMV with Blender 2.49 and Windows 7.

I have the folder MGLToolsPckgs in the a directory of my choice. I insert within the content of ePMV.zip. OK.

When I do the following:
1/ Open Blender
2/ Open the text editor
3/ Click on Text->Open and browse to my MGLTools directory then ePMV and select install_plugin.py and click "Open Text File"
4/ Click on Text->Run Python Script. Here is the problem. Effectively, as supposed in the website, the script guess wrong in finding the current MGLToolsPckgs directory. BUT I can not change the directory path, there is directly an error message saying Python script error: check the console.

May you tell me how to change the path when I have to run the python script ?

Many thanks for your help

Damien


Top
 Profile  
 
PostPosted: Sun Mar 20, 2011 5:00 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi Damien,

when you say the script guess wrong what did he guess ? The script should show you the directory where you have extract MGLToolsPckgs not the MGLToolsPCkgs directory itself.
Can you show the content of the console

Ludovic


Top
 Profile  
 
PostPosted: Mon Mar 21, 2011 9:13 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Mar 19, 2011 6:31 pm
Posts: 8
Hi Ludovic, many thanks for the fast reply.

So I followed the instructions from the website Installation => Get and install the latest version:

. Open blender, open the Text windows panel, click on Tex->Open and browse to your MGLTools directory then ePMV and select install_plugin.py and click "Open Text File"
. Click on Text->Run Python Script. Follow the instruction. The script show you the current MGLToolsPckgs directory. If the script guess wrong you can change it. Click install and wait.

When I run the script I obtain directly an error message. I join a screen capture of the Blender interface and the console.

Thanks

Damien


Attachments:
Console.JPG
Console.JPG [ 176.2 KiB | Viewed 10778 times ]
Top
 Profile  
 
PostPosted: Mon Mar 21, 2011 4:03 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
hi damien,

ok try to install numpy, numpy-1.5.1-win32-superpack-python2.6.exe here : http://sourceforge.net/projects/numpy/f ... e/download
and try again

Ludo


Top
 Profile  
 
PostPosted: Tue Mar 22, 2011 8:21 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Mar 19, 2011 6:31 pm
Posts: 8
Hi Ludo,

I installed numpy. The installation seemed to process correctly since (after Blender restart) I can found ePMV in Scripts -> ePMV (see screenshot).

However, I get an error message when I launch ePMV (see console screenshot).

Damien


Attachments:
Blender_console.jpg
Blender_console.jpg [ 173.61 KiB | Viewed 10745 times ]
Blender_script_view.jpg
Blender_script_view.jpg [ 88.37 KiB | Viewed 10745 times ]
Top
 Profile  
 
PostPosted: Tue Mar 22, 2011 3:55 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi damien,

look like you are trying to run the previous version of ePMV.
- go in C:\USers\Damien\AppData\Roaming\Blender Foundation\Blender\.blender\script\ and remove blenderPmvScriptGUI.py. In the same directory look for a file call mgltoolsdir file, open and check it point to C:\Tools
- go in C:\Tools\MGLToolsPckgs check if a file called patched exist. verify also in C:\Tools.
The idea of the installtion is to copy the plugin file in the .blender\script, but more importantly to patched MGLTools to work on windows with python2.6.6. Its why you should have a patched file in MGLToolsPckgs that indicate the instalation went well and that you have the right python module.

anyway, I am confused that you got the old plugin.
so we may have to install manually (no so hard):
- copy ePMV/plugin/epmv_blender_plugin.py and epmv_blender_update.py in C:\USers\Damien\AppData\Roaming\Blender Foundation\Blender\.blender\script\
- add or modify the mgltoolsdir file in C:\USers\Damien\AppData\Roaming\Blender Foundation\Blender\.blender\script\ to point to C:\Tools
- download and extract the patched file for MGLTools in MGLToolsPckgs (this will replace some python module) http://mgldev.scripps.edu/projects/ePMV ... tPckgs.tar then create a file called patched.

try to run ePMV

Let me know all your finding.

Ludovic


Top
 Profile  
 
PostPosted: Tue Mar 22, 2011 5:18 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Mar 19, 2011 6:31 pm
Posts: 8
Hi Ludo,

I describe the process step by step. My comments are in red:

- go in C:\USers\Damien\AppData\Roaming\Blender Foundation\Blender\.blender\script\ and remove blenderPmvScriptGUI.py DONE. In the same directory look for a file call mgltoolsdir file, open and check it point to C:\Tools YES

- go in C:\Tools\MGLToolsPckgs check if a file called patched exist YES. verify also in C:\Tools NO.

- copy ePMV/plugin/epmv_blender_plugin.py and epmv_blender_update.py in C:\USers\Damien\AppData\Roaming\Blender Foundation\Blender\.blender\script\ They are older. So I did not copy them. Do I replace them anyway ?

- add or modify the mgltoolsdir file in C:\USers\Damien\AppData\Roaming\Blender Foundation\Blender\.blender\script\ to point to C:\Tools It already pointed to C:\Tools

- download and extract the patched file for MGLTools in MGLToolsPckgs (this will replace some python module) http://mgldev.scripps.edu/projects/ePMV ... tPckgs.tar then create a file called patched. Extraction done. A file called Patched already existed...

When I run Blender then ePMV I got the runtime error two successive times (see screenshots). I started Blender again and got the same runtime error. I join the console (2 screenshots) but by email (too big visibly).

Damien


Attachments:
Runtime_error.JPG
Runtime_error.JPG [ 26.84 KiB | Viewed 10726 times ]
Top
 Profile  
 
PostPosted: Tue Mar 22, 2011 5:27 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
Hi damien,

ok sound like your almost done. This runtime error is already known (http://epmv.scripps.edu/troubleshooting). I dont know why it popup but it doesnt mean that epmv is not working.
So launch blender, clikc OK at the runtime error, a second one appear click OK. Now try to launch ePMV from the Scripts windows and let me know it its working.

Ludo-


Top
 Profile  
 
PostPosted: Tue Mar 22, 2011 5:30 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Mar 19, 2011 6:31 pm
Posts: 8
Hi Ludo,

I always get the runtime error.

Damien


Top
 Profile  
 
PostPosted: Tue Mar 22, 2011 5:31 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Sat Mar 19, 2011 6:31 pm
Posts: 8
Here is the console


Attachments:
Console_during_Runtime.JPG
Console_during_Runtime.JPG [ 31.71 KiB | Viewed 10725 times ]
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
POWERED_BY
Translated by Maël Soucaze © 2009 phpBB.fr