The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Tue Jan 16, 2018 7:55 am

All times are UTC




Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Installation of EPMV
PostPosted: Thu Mar 10, 2011 4:14 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Thu Mar 10, 2011 4:06 pm
Posts: 6
Hi All,

I am just installing the ePMV plugin into Blender 2.49b. I am running Fedora Core 8 and have python, Blender and MGLtools running fine.
I followed the instruction on the web page to install the plug-in via Blender and I manage to run the installation script, however after I indicate the path of the MGLToolsPckgs I get the following error message in the terminal window:

Traceback (most recent call last):
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/ePMV/installer.py", line 803, in Command
self._command(args)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/pyubic/uiAdaptor.py", line 126, in _command
self._callElem(block,evt)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/pyubic/uiAdaptor.py", line 102, in _callElem
self._callElemAction(elem)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/pyubic/uiAdaptor.py", line 87, in _callElemAction
self.callbackaction(item)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/pyubic/uiAdaptor.py", line 65, in callbackaction
item['action'](*args)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/ePMV/installer.py", line 826, in getMGL
filename = args[0]
IndexError: tuple index out of range



Any ideas on what I maigh be doing wrong ? or on to solve it ? I also tried to install in a different place but no success..

Thanks

Afonso


Top
 Profile  
 
 Post subject: Re: Installation of EPMV
PostPosted: Thu Mar 10, 2011 7:30 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
hi Afonso

its en error in the too earlier release of ePMV. I think I have now fixed mpost of the install script error.
get the new archive from the website https://sites.google.com/site/mgltoolsepmv/installation/get-latest or directly here http://mgldev.scripps.edu/projects/ePMV/epmv.zip.

Let me know if the script still give you error.

Ludovic


Top
 Profile  
 
 Post subject: Re: Installation of EPMV
PostPosted: Fri Mar 11, 2011 12:54 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Thu Mar 10, 2011 4:06 pm
Posts: 6
Dear Ludovic,

Thanks for the reply. I downloaded the new files and installed everything from zero. However I still got the same error message as before... :(

I also tried to install in Windows Vista. There I also have an error but it seems to be related with the python version installed. Could you let me know if I really need to install python 2.5 and cannot use 2.7? (at the moment I have both because of ePMV).

Best

Afonso


Top
 Profile  
 
 Post subject: Re: Installation of EPMV
PostPosted: Fri Mar 11, 2011 5:07 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
hi,

i am sorry its still not working. In linux when you run the script what is the path that appear in the input field? did you change it ?
can you show me the complete log in the terminal?

for windows you need a clean installation of python2.6.6, then get the MGLToolsPCkgs not the installer (avoid installing python2.5). I need to do some more test on windows so keep trying on linux.

L


Top
 Profile  
 
 Post subject: Re: Installation of EPMV
PostPosted: Mon Mar 14, 2011 8:51 am 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Thu Mar 10, 2011 4:06 pm
Posts: 6
Hi Ludovic,

Thanks for the help,

I restarted Blender and open the install_plugin.py and run it, it ask for the path and I copy/past it on the space, then it goes back to the python code and the log on the terminal i got is this one:

[duartea@c155111 ePMV]$ blender
Compiled with Python version 2.5.2.
Checking for installed Python... got it!
install_plugin.py
MGL /home/duartea/Download/mgltools_i86Linux2_1.5.6
__main__
/home/duartea/Download
args ()
Traceback (most recent call last):
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/ePMV/installer.py", line 803, in Command
self._command(args)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/pyubic/uiAdaptor.py", line 126, in _command
self._callElem(block,evt)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/pyubic/uiAdaptor.py", line 102, in _callElem
self._callElemAction(elem)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/pyubic/uiAdaptor.py", line 87, in _callElemAction
self.callbackaction(item)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/pyubic/uiAdaptor.py", line 65, in callbackaction
item['action'](*args)
File "/home/duartea/Download/mgltools_i86Linux2_1.5.6/ePMV/installer.py", line 826, in getMGL
filename = args[0]
IndexError: tuple index out of range
path /home/duartea/Download/mgltools_i86Linux2_1.5.6/ePMV
MGL /home/duartea/Download/mgltools_i86Linux2_1.5.6
__main__

After this I don't have any more info... i tried it from different directories were I have read/ write permissions but the error message is the same.

Best

Afonso


Top
 Profile  
 
 Post subject: Re: Installation of EPMV
PostPosted: Mon Mar 14, 2011 4:05 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
hi Afonso

ok I see a first problem.
the ePMV and pyubic folder have to go in MGLToolsPckgs directory not mgltools_i86Linux2_1.5.6.
so juste move them in MGLToolsPckgs
launch blender, and run install_plugin.py look at the path that appear in the dialog.It should be /home/duartea/Download/mgltools_i86Linux2_1.5.6
again show me what happen in the console.

If this still don't work, try a manual installation :
- create a text file mgltoolsdir in your .blender/script folder ~/.blender/scripts
the content of the file is "/home/duartea/Download/mgltools_i86Linux2_1.5.6"
- copy epmv_blender_plugin.py from /home/duartea/Download/mgltools_i86Linux2_1.5.6/MGLToolsPckgs/ePMV/blender/plugin to
'~/.blender/scripts'
Restart blender, you should see ePMV in your script windows, under system.

Ludovic


Top
 Profile  
 
 Post subject: Re: Installation of EPMV
PostPosted: Mon Mar 14, 2011 6:53 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Thu Mar 10, 2011 4:06 pm
Posts: 6
"ok I see a first problem.
the ePMV and pyubic folder have to go in MGLToolsPckgs directory not mgltools_i86Linux2_1.5.6.
so juste move them in MGLToolsPckgs
"

Thanks! It solved the problem! I got some errors regarding the Python but i solved them and it is running nicely now!

Now i will go back and try my luck with the Windows Vista installation.

Thanks

Afonso


Top
 Profile  
 
 Post subject: Re: Installation of EPMV
PostPosted: Mon Mar 14, 2011 10:26 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
great!
good luck with the windows installation.
some tips:
-last python installed should be python2.6.6, actually best is to remove all python version, then install python2.6.6
-the installation on windows require pacth to apply in the MGLToolsPCkgs directory, which is downloading the package compatible with python2.6.6
so if the installation didnt work, i can provide the link for the py26 pacakge and you can put them manually..

let me know

Ludovic


Top
 Profile  
 
 Post subject: Re: Installation of EPMV
PostPosted: Wed Mar 16, 2011 8:59 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Thu Mar 10, 2011 4:06 pm
Posts: 6
Hi,

Just made a clean installation of python 2.6.6 on my Windows Vista ( no other python versions are installed). Also downloaded the tools and the ePMV zip file from the website and place it under the pcks. Run the script like in the instructions and got he following error.

Any suggestion ?

Thanks

Afonso


Attachments:
ePMVerror.jpg
ePMVerror.jpg [ 228.88 KiB | Viewed 8987 times ]
Top
 Profile  
 
 Post subject: Re: Installation of EPMV
PostPosted: Wed Mar 16, 2011 9:40 pm 
Offline
Picomolar User
Picomolar User
User avatar

Joined: Wed Apr 22, 2009 2:08 am
Posts: 235
hi,

of course I have,thats mean the installation is not working for windows. I will try to get something running.
meanwhile here is what you can do (manual patch of MGL). Two possibility :

1- you need the MGLKToolsPkgs for python2.6.6 : http://mgldev.scripps.edu/projects/ePMV/patchs/depdtPckgs.tar
extract this archive in MGLToolsPkgs directort (where pyubic and epmv are), this should replace all the depdt pacakges such as bhtree, UTPakacge etc. ..
create an empty file named patched in MGLToolsPkgs
redo the installation.
OR
2- install numpy 32bit for windows and python2.66 numpy-1.5.1-win32-superpack-python2.6.exe
http://sourceforge.net/projects/numpy/files/NumPy/1.5.1/numpy-1.5.1-win32-superpack-python2.6.exe/download
redo the installation which will patch MGL for you
in any case you need python 2.6.6 32bits, seems you have it
Let me know
Ludovic


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
POWERED_BY
Translated by Maël Soucaze © 2009 phpBB.fr