The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Sat Sep 22, 2018 1:54 am

All times are UTC

Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Aug 19, 2013 11:09 pm 
Millimolar User
Millimolar User
User avatar

Joined: Mon Aug 19, 2013 10:49 pm
Posts: 1
Hi, I'm running Raccoon2 on my virtual machine Window 7 64 bit system. I was able to follow the Quickstart guide to set up a test experiment up to the job submission point. The problem is after clicking OK to start the submission, I got the following error:

<type 'exceptions.KeyError'> Exception in Tk callback
Function: <bound method JobManagerTab.submit of <CADD.Raccoon2.gui.EE_jobmanager.JobManagerTab instance at 0x0A859878>> (type: <type 'instancemethod'>)
Args: ()
Traceback (innermost last):
File "C:\Program Files\MGLTools-1.5.7rc1\lib\site-packages\Pmw\Pmw_1_3\lib\", line 1747, in __call__
return apply(self.func, args)
File "C:\Program Files\MGLTools-1.5.7rc1\lib\site-packages\CADD\Raccoon2\gui\", line 227, in submit
File "C:\Program Files\MGLTools-1.5.7rc1\lib\site-packages\CADD\Raccoon2\gui\", line 264, in submit_cluster
submission =, duplicates=choice)
File "C:\Program Files\MGLTools-1.5.7rc1\lib\site-packages\CADD\Raccoon2\gui\", line 979, in submitSsh
File "C:\Program Files\MGLTools-1.5.7rc1\lib\site-packages\mglutil\", line 87, in dispatchEvent
File "C:\Program Files\MGLTools-1.5.7rc1\lib\site-packages\CADD\Raccoon2\gui\", line 504, in updateTreeItem
File "C:\Program Files\MGLTools-1.5.7rc1\lib\site-packages\CADD\Raccoon2\gui\", line 839, in expandNode['username'],
<type 'exceptions.KeyError'>: 'username'

I got the similar 'username' error when I tried to update the status or download results etc.
The strange thing is it appeared to run on the cluster to some extent, since I got the .tar.gz file. However, it didn't produce the summary log file so I couldn't look at the result with Raccoon.

Note: I checked 'Save password' in Connection Manager so I don't think there is a connection problem, unless Raccoon2 uses my Windows user name which is different from my cluster user name...

Any help is appreciated. Thanks.

Edited: I tried the Linux version and got the same 'username' error. I was using Ubuntu 10.0.4. However, I also noticed that it was sufficient to copy the entire data folder from the cluster manually, unzip the .tar.gz, and choose 'Process directory (Vina)' to look at the results. Nevertheless, it will be more convenient to be able to update the job status and download the data within Raccoon2.

PostPosted: Thu Feb 04, 2016 9:35 pm 
Millimolar User
Millimolar User
User avatar

Joined: Tue Dec 04, 2012 4:09 pm
Posts: 6
I am also getting the same error message while running Raccoon2 on a linux cluster (100 cores). As a trial I started a docking run for around 3,000 molecules and after more than 24 hours the status is still "Running". Thus, I am not sure whether it is really doing something or the "username" error mentioned by achan is causing something. Can someone please help? Thank you in advance!

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Translated by MaĆ«l Soucaze © 2009