The Molecular Graphics Laboratory Forum
http://mgl.scripps.edu/forum/

error reported in Python Shell
http://mgl.scripps.edu/forum/viewtopic.php?f=27&t=3349
Page 1 of 1

Author:  wang [ Wed Dec 14, 2016 4:16 am ]
Post subject:  error reported in Python Shell

Dear all,

when I launch PMV, I got error message in Python shell as below. I wonder what could be the problem and how to solve it? Thank you very much!!

Chunguang :cry: :cry: :cry:



Python 2.5.6 (r256:88840, Oct 26 2012, 16:44:06)
[GCC 4.0.1 (Apple Inc. build 5465)] on darwin
Type "copyright", "credits" or "license()" for more information.

****************************************************************
Personal firewall software may warn about the connection IDLE
makes to its subprocess using this computer's internal loopback
interface. This connection is not visible on any external
interface and no data is sent to or received from the Internet.
****************************************************************

IDLE 1.2.6 ==== No Subprocess ====
>>> dlopen(/Library/MGLTools/1.5.6/MGLToolsPckgs/UTpackages/UTvolrend/_UTVolumeLibrary.so, 2): Symbol not found: _glGetColorTableEXT
Referenced from: /Library/MGLTools/1.5.6/MGLToolsPckgs/UTpackages/UTvolrend/_UTVolumeLibrary.so
Expected in: /usr/X11/lib/libGL.1.dylib

Cannot import grid3DCommands. Disabling grid3DCommands...
ERROR *********************************************
Traceback (most recent call last):
File "/Library/MGLTools/1.5.6/MGLToolsPckgs/ViewerFramework/VF.py", line 898, in tryto
result = command( *args, **kw )
File "/Library/MGLTools/1.5.6/MGLToolsPckgs/Pmv/APBSCommands.py", line 4034, in checkDependencies
from Volume.Renderers.UTVolumeLibrary import UTVolumeLibrary
File "/Library/MGLTools/1.5.6/MGLToolsPckgs/Volume/Renderers/UTVolumeLibrary/UTVolumeLibrary.py", line 2, in <module>
from UTpackages.UTvolrend.UTVolumeLibrary import *
File "/Library/MGLTools/1.5.6/MGLToolsPckgs/UTpackages/UTvolrend/UTVolumeLibrary.py", line 7, in <module>
import _UTVolumeLibrary
ImportError: dlopen(/Library/MGLTools/1.5.6/MGLToolsPckgs/UTpackages/UTvolrend/_UTVolumeLibrary.so, 2): Symbol not found: _glGetColorTableEXT
Referenced from: /Library/MGLTools/1.5.6/MGLToolsPckgs/UTpackages/UTvolrend/_UTVolumeLibrary.so
Expected in: /usr/X11/lib/libGL.1.dylib

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/