Page 1 of 1

trouble running docking job on PyRx 0.9.3

PostPosted: Tue Feb 23, 2016 4:48 pm
by jmeans
I purchased the latest version of PyRx to use on Fedora 23. It installed without trouble. When I run a docking job, though, I get the following scripting error after the job is complete:

Traceback (most recent call last):
File "/usr/local/PyRx-0.9.3/lib64/python2.6/site-packages/wx/", line 14656, in <lambda>
lambda event: event.callable(*event.args, ** )
File "/usr/local/PyRx-0.9.3/lib64/python2.6/site-packages/PyRx/", line 389, in CheckResults
index = self.ligands.index(ligand)
ValueError: list.index(x): x not in list

When I inspect the .dlg file, it says that the job terminated successfully. However, PyRx is reporting that the job is still running, and it will not move onto the next docking job. Instead, I get the error shown above.

Re: trouble running docking job on PyRx 0.9.3

PostPosted: Wed Feb 24, 2016 1:37 am
by sargis
Thank you for purchasing PyRx and sorry about that. Would you please use File -> Export... menu and send me the output PyRx_workspace.tar.gz file. I need ~/.PyRx_workspace/Macromolecules/ folder corresponding this autodock run and ~/.PyRx_workspace/Ligands files used.

I've made a new update recently that was related to a problem of updating grid box dimension reported in Problem with flexible docking (Windows 0.93). Please use Help->Check for Updates... option to apply this fix.

I would be happy to fix this scripting error once I'm able to reproduce this error on my computer.

Thank you.

Re: trouble running docking job on PyRx 0.9.3

PostPosted: Wed Feb 24, 2016 2:28 am
by sargis
I've just uploaded a new update that would make it easier to debug this. Instead of sending PyRx_workspace.tar.gz, please use Help->Check for Updates... menu to apply this update. Please do the same steps as you did before. Then click on Python Shell tab on the Controls panel; it will have a list of ligands and the name of that particular ligand that causes this error printed, if it encounters the same error. Use Ctrl+a to select all, Ctrl+c to copy and Ctrl+v to paste that text in reply to this message.

Thank you again.

Re: trouble running docking job on PyRx 0.9.3

PostPosted: Wed Feb 24, 2016 2:29 pm
by jmeans

Yesterday after I made my initial post, I continued to troubleshoot the problem. My students are working on two different computational projects - one involving an RNA target and the other involving a protein target. They are docking different ligands with each of these targets. We were consistently getting the posted error with the RNA target with its group of ligands. I tried docking ligands from the protein project with the RNA and still got the same error. I tried running the protein target with some of its ligands, and I did not get that error; the docking results were displayed as expected. Also, I never got this error when using the Vina Wizard; I only got it with the AutoDock Wizard. Additionally, all of these files had been successfully docked with version 0.9 of PyRx on Fedora 20. I pulled two random RNA structures and one random protein structure from the PDB site. I got the same error running dockings with any of our ligands and all three of these random structures. Each time, I would have to restart Python Prescription, so the program was being restarted each time. This morning, I came in to continue troubleshooting, and I ran the update as you requested. I ran two docking jobs with the RNA target and ligands that had produced the error yesterday. I did not get the error on either job; they both posted the docking results as expected. I don't know if running the update ended up taking care of it, or if restarting the computer had done it. I shut it down yesterday before I left. I don't know if my student had shut down the machine at all since she started seeing these errors. Either way, it seems to be taken care of at this point. If the error rears its head again, I'll certainly follow your post to get the necessary info for you to troubleshoot it further.

Thank you.

Re: trouble running docking job on PyRx 0.9.3

PostPosted: Wed Feb 24, 2016 3:38 pm
by sargis
Thank you John. It's possible that I introduced this bug between PyRx version 0.9 and 0.9.3. The workflow for the AutoDock Wizard is a bit more complex compared to the Vina Wizard because of the additional step of making grid files. This might explain why this works with the Vina Wizard, but not with AutoDock Wizard. I've seen also a case when for a particular run, AutoDock would work but not Vina because Vina is more stick about file format. I try to fix these kind of bugs to make sure that both AutoDock and Vina work for the same receptor-ligand complex. I'm also working to make sure that there will be less need to restart PyRx.

The update I've uploaded yesterday, would skip the error you reported and would print the list of ligands and the name of the ligand that caused the error in Python Shell. Glad to see that this error seems to be taken care of at this point. Yes, please do follow on this post and copy any messages you see in Python Shell so I can troubleshoot it further.

Thank you.

Re: trouble running docking job on PyRx 0.9.3

PostPosted: Sat Mar 12, 2016 12:46 pm
by bsantoso
sorry, for out of topic.

Hi Sargis,

It's solved. I re-downloaded your link again. Now, it's 0.9.4.

PyRx 0.9.4 version has been released. Can I update my 0.9.3 version to this version? I have clicked check for update, but nothing happened, only said it's 0.9.3.