Problem Upgrading to Latest Version in Debian Wheezy

Python Prescription - Virtual Screening Tool

[PyRx is no longer developed at MGL]

Moderator: sargis

Forum rules
[PyRx is no longer developed at MGL]

Problem Upgrading to Latest Version in Debian Wheezy

Postby smolnar » Mon Jun 09, 2014 2:48 pm

I can run PyRx v-0.7 in the 64 bit Debian Wheezy with i386 architecture implemented without any problems.

When I upgrade to PyRx v-0.9 I get no errors from the installer and run.sh opens the gui but then I get a segmentation fault. The error messages are:

]0;computation@AbNormal: ~/Apps/PyRx-0.9computation@AbNormal:~/Apps/PyRx-0.9$ ./run.sh

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libxfce.so: wrong ELF class: ELFCLASS64

(python:25888): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -2 and height 10

(python:25888): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -2 and height 10

(python:25888): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 10
Segmentation fault

Unfortunately, I have no idea as to how to fix the problem and would be most appreciative of assistance.

Thanks in advance.
User avatar
smolnar
Micromolar User
Micromolar User
 
Posts: 49
Joined: Sat Aug 08, 2009 2:38 pm

Re: Problem Upgrading to Latest Version in Debian Wheezy

Postby sargis » Mon Jun 09, 2014 3:55 pm

Please consider purchasing 64-bit PyRx. There are these links that might help getting 32-bit programs to run on 64 bit Linux Debian/Ubuntu http://dullsharpness.com/tag/elfclass64/ http://plosquare.blogspot.com/2008/12/g ... ass64.html
User avatar
sargis
Picomolar User
Picomolar User
 
Posts: 583
Joined: Fri Oct 17, 2008 10:39 pm


Return to PyRx

Who is online

Users browsing this forum: No registered users and 1 guest