Cannot launch PyRx 0.8 in Linux Ubuntu 16.04 LTS

Python Prescription - Virtual Screening Tool

[PyRx is no longer developed at MGL]

Moderator: sargis

Forum rules
[PyRx is no longer developed at MGL]

Cannot launch PyRx 0.8 in Linux Ubuntu 16.04 LTS

Postby benny » Mon Oct 17, 2016 4:17 am


I tried to launch the PyRx in Linux Ubuntu 16.04 LTS but received the following error:

Traceback (most recent call last):
File "/home/ben/Desktop/PyRx/", line 71, in <module>
File "/home/ben/Desktop/PyRx/", line 39, in startPyRx
frame = MainFrame(None, -1, size=(width, height-200))
File "/home/ben/Desktop/PyRx/lib/python2.6/site-packages/PyRx/", line 129, in __init__
import preferences
File "/home/ben/Desktop/PyRx/lib/python2.6/site-packages/PyRx/", line 22, in <module>
from traitedBabel import openbabelParameters, openbabelAutoDockParameters
File "/home/ben/Desktop/PyRx/lib/python2.6/site-packages/PyRx/", line 7, in <module>
from enthought.tvtk.pyface.decorated_scene import DecoratedScene
File "/home/ben/Desktop/PyRx/lib/python2.6/site-packages/Mayavi-3.3.1-py2.6-linux-i686.egg/enthought/tvtk/pyface/", line 13, in <module>
DecoratedScene = toolkit_object('decorated_scene:DecoratedScene')
File "/home/ben/Desktop/PyRx/lib/python2.6/site-packages/Mayavi-3.3.1-py2.6-linux-i686.egg/enthought/tvtk/pyface/", line 93, in toolkit_object
File "/sargis/PyRx_new/lib/python2.6/site-packages/Mayavi-3.3.1-py2.6-linux-i686.egg/enthought/tvtk/pyface/ui/wx/", line 29, in <module>
File "/home/ben/Desktop/PyRx/lib/python2.6/site-packages/Mayavi-3.3.1-py2.6-linux-i686.egg/enthought/tvtk/", line 11, in <module>
from enthought.tvtk.tvtk import tvtk
File "/home/ben/Desktop/PyRx/lib/python2.6/site-packages/Mayavi-3.3.1-py2.6-linux-i686.egg/enthought/tvtk/", line 42, in <module>
import vtk
File "/home/ben/Desktop/PyRx/lib/python2.6/site-packages/vtk/", line 63, in <module>
__helper.refine_import_err('rendering', 'vtkRenderingPython', exc)
File "/home/ben/Desktop/PyRx/lib/python2.6/site-packages/vtk/", line 32, in refine_import_err
raise LinkError, str(exc)
LinkError: cannot open shared object file: No such file or directory

I tried install the 32 bit version of libXt using the following command:

sudo apt-get install libxtst6:i386

but it still give the same error message.

Please help!

User avatar
Millimolar User
Millimolar User
Posts: 1
Joined: Mon Oct 17, 2016 4:11 am

Return to PyRx

Who is online

Users browsing this forum: No registered users and 4 guests