The Molecular Graphics Laboratory Forum

AutoDock, AutoLigand, MGLTools, Vina, PyRx and more.
It is currently Fri Sep 21, 2018 7:54 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed Jun 05, 2013 8:41 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Wed Jun 05, 2013 7:58 pm
Posts: 1
I have downloaded and installed (via .dmg) no problems. On startup I get an error " _imaging C module is not installed" (pasted below). I found an older post that indicated I should install the Python Imaging Environment (http://www.pythonware.com/products/pil/). This did not find support for jpeg, freetype2 or littlecms, and it also did not fix the error below (but perhaps I've put it in the wrong location?).

Could anyone help please? I know enough to mess things up, but not enough to fix them :/

Cheers - Christina

Starting X11
setting PYTHONHOME environment
Run PMV from /Library/MGLTools/1.5.6/MGLToolsPckgs/Pmv
The _imaging C module is not installed
Resource file used to customize PMV: /Users/christina/.mgltools/1.5.6/Pmv/_pmvrc
Traceback (most recent call last):
File "/Library/MGLTools/1.5.6/MGLToolsPckgs/Pmv/__init__.py", line 381, in runPmv
title=title, withShell= not interactive, verbose=False, gui=gui)
File "/Library/MGLTools/1.5.6/MGLToolsPckgs/Pmv/moleculeViewer.py", line 843, in __init__
trapExceptions=trapExceptions)
File "/Library/MGLTools/1.5.6/MGLToolsPckgs/ViewerFramework/VF.py", line 372, in __init__
verbose=verbose)
File "/Library/MGLTools/1.5.6/MGLToolsPckgs/ViewerFramework/VFGUI.py", line 331, in __init__
self.collapsePhoto = ImageTk.PhotoImage(file=filename)
File "/Library/MGLTools/1.5.6/lib/python2.5/site-packages/PIL/ImageTk.py", line 116, in __init__
self.paste(image)
File "/Library/MGLTools/1.5.6/lib/python2.5/site-packages/PIL/ImageTk.py", line 166, in paste
im.load()
File "/Library/MGLTools/1.5.6/lib/python2.5/site-packages/PIL/ImageFile.py", line 155, in load
self.load_prepare()
File "/Library/MGLTools/1.5.6/lib/python2.5/site-packages/PIL/PngImagePlugin.py", line 339, in load_prepare
ImageFile.ImageFile.load_prepare(self)
File "/Library/MGLTools/1.5.6/lib/python2.5/site-packages/PIL/ImageFile.py", line 221, in load_prepare
self.im = Image.core.new(self.mode, self.size)
File "/Library/MGLTools/1.5.6/lib/python2.5/site-packages/PIL/Image.py", line 35, in __getattr__
raise ImportError("The _imaging C module is not installed")
ImportError: The _imaging C module is not installed
Please install installed to fix this problem.


Top
 Profile  
 
PostPosted: Mon Jun 10, 2013 6:08 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Mon Jun 10, 2013 5:40 pm
Posts: 1
I do have the same error with image C module. I tried downloading the older version of autodock, after deleting the current version, and that still did not work. It is strange because i had the older version worked on the same computer.


Top
 Profile  
 
PostPosted: Thu Aug 08, 2013 6:48 pm 
Offline
Millimolar User
Millimolar User
User avatar

Joined: Thu Aug 08, 2013 6:44 pm
Posts: 2
Hi,

Try this:

sudo chmod 755 /Library/MGLTools/1.5.6/lib/libjpeg.62.dylib

It appears that the libjpeg library file permissions are set to only rwx------. Once the permissions were changed, the ADT interface fired right up for me.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
POWERED_BY
Translated by MaĆ«l Soucaze © 2009 phpBB.fr